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By far the most common problems that installers have with RHAON can be traced 
to network infrastructure. The following are troubleshooting steps and setup rec-
ommendations for RHAON networks. 
 
Symptom: RHAON reports “No CobraNet Devices found.” 
 
1) Are you trying to use a Wi-Fi connection? RHAON must use a wired Ethernet con-

nection; Wi-Fi doesn’t have sufficient bandwidth. Switch to a wired connection. 
2) Have you set a private IP address on your Ethernet Network Interface Card (NIC)?  

a) Windows 7 or Vista: Start: Control Panel\All Control Panel Items\Network and 
Sharing Center\Local Area Connection, click Properties, then select Internet Pro-
tocol Version 4, click Properties, Click “Use the following IP Address,” enter: IP 
address: 192.168.1.1 ; Subnet mask: 255.255.255.0; other fields are left blank. 
(Note, other private IP ranges can be used, see RHAON manual for details.) 

b) Windows XP: Start: Settings\Control Panel\Network Connections\Local Area 
Connection, click Properties, then select Internet Protocol (TCP/IP), click Proper-
ties, Click “Use the following IP Address,” enter: IP address: 192.168.1.1 ; Sub-
net mask: 255.255.255.0; other fields are left blank. (Note, other private IP ranges 
can be used, see RHAON manual for details.) 

3) Have you selected the correct NIC in RHAON? 
a) In RHAON, Options > Preferences in the Adaptor dropdown, select the correct 

NIC—the same one you configured in step two above.  
4) Have you set RHAON to manage the correct IP Range? 

a) In RHAON, Options > Preferences set the IP Range to 192.168.1.2 to 
192.168.1.100. (Note, other private IP ranges can be used, see RHAON manual 
for details.) 

5) In RHAON select File > Network Manager. Wait for a minute or so, does the list 
populate with your RHAON/CobraNet devices. If not, something is blocking Cobra-
Net packets or you have a network problem. 
a) Disable any third-party software firewalls and network security software. Ver-

sions of Zone Alarm, Norton Internet Security and McAfee Internet Security are 
know to block CobraNet packets and must be disabled to use RHAON. The Win-
dows Firewall can remain on. 

b) If you have disabled any security software and still can’t see any CobraNet de-
vices in Network Manager, simplify your network. 
i) Connect directly to a single RHAON device using a known-good cable, by-

passing all installed network infrastructure including switches. Many laptops 
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have auto-switching NICs and do not require a crossover cable. Check the 
communication lights on the port, rapid flashing green indicates a connection. 

c) If you still cannot see any devices in Network Manager and you’ve double-
checked all of the above, you may need to update the drivers for your NIC or try a 
different NIC.  

 
Symptom: My RHAON device is slow to synchronize and slow to save. 
 
1) RHAON can be somewhat sluggish as it is relegated to second-class status by Co-

braNet, but if synchronizing and saving take more than 20-30 seconds, you may have 
a network problem.  
a) Start CobraNet Discovery and look at the error count for all devices. Any device 

that shows errors has a suspect network connection. See next step for trouble-
shooting. 

b) Disable any CobraNet transmitters, especially any multi-cast bundles. You want 
to minimize network traffic during setup. 

c) See large system section below if you have more than 20-25 RHAON devices. 
 
Symptom: I see errors reported in CobraNet Discovery for a device or devices. 
 
1) Try a different port on the switch 
2) Qualify the cable. The cable must be able to qualify at 100 mbps. 
3) Check for split pairs. A split pair cable will drop packets even if it’s only 2 meters 

long. 
4) Re-make the RJ45 connector. A marginal or corroded crimp will cause dropped pack-

ets. 
5) Check the cable length. The Ethernet standard for unshielded twisted pair copper ca-

bles is a maximum 100 meters/330 feet. Cables longer than this will not support Co-
braNet streaming audio. 

 
Symptom: CobraNet audio has clicks, dropouts or sounds distorted. 
 
1) Check with CobraNet discovery. If you see errors increasing for a device, this means 

that packets are likely being lost and distorted audio is the result. 
2) Double check the source. If all of the CobraNet devices are sounding distorted, the 

problem is likely at the source. 
 
Symptom: CobraNet audio works until the system is power-cycled, but doesn’t re-
sync upon power up. 
 
1) Check the conductor priority. See the CobraNet Discovery section below for details.  
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Symptom: Devices are dropping offline and re-syncing 
 
1) Increase the Offline Timeout setting in RHAON. See the Large System recommenda-

tions below. 
2) If you have a small system, check for network errors in CobraNet Discovery.  
 
Symptom: I can communicate with my Iconyx array, but I get errors when writing 
beams. 
1) This is a classic symptom of network problems. Start CobraNet Discovery and look at 

the error count for all devices. Any device that shows errors has a suspect network 
connection. See the CobraNet Discovery section above for troubleshooting. See Us-
ing CobraNet Discovery section below if you are new to Discovery. 

 
Symptom: Analog Audio or Wink with Audio works, but not CobraNet Audio. 
 
1) Check to be sure that you have set the correct bundle and channel in the CobraNet 

Routing Section on the Connect tab of the device. If the RHAON device is receiving 
a CobraNet stream, the Channels in the receiver section will change to green and 
show the Bit rate, the Sample rate and the Latency 

2) The receivers show the bit rate, sample rate and latency, but are red and still no audio. 
Check to be sure that your RHAON unit is set to the correct CobraNet latency and 
sample rate.  
a) To view/change the latency, minimize the RHAON device and then on the Con-

nect tab, right click on the device. 
b) To change the sample rate—from 48 kHz to 96 kHz for example—you must load 

the correct DSP firmware file, see the RHAON manual for your product for de-
tails on this procedure. 

 
Symptom: Analog audio sounds like its gating. 
 
1) You are sending a signal to Analog 1, but some other input is selected on the Connect 

tab. As an aid to troubleshooting Analog 1 will always pass audio, but if some other 
input is selected, Analog 2 for example, the signal to Analog 1 must exceed a thresh-
old, this is why you hear it gating. Select Analog 1 as the input and the gating will 
stop. 

 
Symptom: My Iconyx is slowly flashing the blue wink light. 
 
1) You have the Ethernet cable plugged into a slave unit. Either move the cable to the 

master, or set the unit with the cable to be the master. 
 
Symptom: My IC16R, IC24R, LC32R or IC-Live, Dual shows up as only a single 
IC8 or IC-Live module. 
 
1) Is the wink light flashing slowly? If so you have the Ethernet cable plugged into a 

slave module. Move the cable to the master or reset the DIP switches. 
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2) Check the DIP switches, there must be only one master and the slaves must be indi-
vidually identified.  

3) Did you connect the interconnect cables between the modules and screw down the 
connectors? If not, you must do this. 

4) Has the interconnect ribbon cable been accidently pinched between the cabinets? If 
so, it may be damaged and need replacement. 

 
Symptom: Both the green and amber LEDs on the Ethernet port are flashing. 
 
1) This indicates that this device is the CobraNet Conductor. This is a normal condition. 
2) Normally, the CobraNet source should be the conductor. If your RHAON system is 

using CobraNet audio and one of the RHAON loudspeakers is the Conductor, you 
may experience issues synching to CobraNet audio upon system power-up. See the 
Using CobraNet Discovery section below. If you are not using CobraNet audio, con-
ductor priority is not an issue. 

 
Using Network Manager 
 
RHAON’s Network manager gives the RHAON user some of the functionality of Co-
braNet Discovery without leaving RHAON. To start the Network Manager, select File > 
Network Manager in RHAON 
 

 
 
1) Network Manager communicates on the MAC layer. Network manager will see 

RHAON/CobraNet devices regardless of their IP address. If you see no CobraNet de-
vices in Network Manager, something is blocking CobraNet packets, you have the 
wrong NIC selected in RHAON or there is no network communication.  

2) Network Manager allows you to see the devices on the network, their MAC address, 
IP address name and the manufacturer’s description. A green check mark in Column 
0 indicates that the device is synchronized with the CobraNet network. Age is the 
time in milliseconds since the last status update from the device. 

3) In the image above one of the RHAON devices is showing Timeout. Notice that the 
IP address is set to the wrong subnet. You can change the 
device’s IP by right-mouse clicking on the device. This 
will open the Manage IP dialog. (Image at right) Enter a 
new IP address in the correct subnet and click on Set. 

4) For large RHAON systems, it is recommended that you 
use a fixed startup IP address for all devices, rather than 
having RHAON hand out IPs. To set a startup IP, right-
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mouse click on the device and enter the desired startup IP and click Set. You can en-
ter the currently assigned IP by clicking on Current IP. Clicking on Reset will clear 
the startup IP and reset the device to startup without an IP; RHAON will then assign 
it one upon startup. 

 
 
Using CobraNet Discovery 
 
CobraNet Discovery or “Disco” as it’s commonly called is Cirrus Logic’s trouble shoot-
ing and management utility. Every CobraNet user should download and install the current 
version of Discovery from Cirrus Logic’s website here:  
 
http://www.cobranet.info/downloads 
 

 
 
1) Note: in Windows XP CobraNet Discovery v3.45 can run concurrently with RHAON; 

Windows Vista and Windows 7 require CobraNet Discovery v4.0X, which must NOT 
run concurrently with RHAON. 

2) CobraNet Discovery looks much like Network manager, but with additional columns. 
3) The IP, MAC, Description and Name columns are the same as in Network Manager. 

You can change the IP address in Disco by right-mouse clicking on the device and se-
lecting New IP Address. You cannot set a startup IP address in Disco; you must do 
that in Network manager in RHAON. 

4) The errorCount column lists any CobraNet errors. The only acceptable value is 0, any 
errors should be investigated; see above troubleshooting steps.   

5) The condStatus column indicates which CobraNet device is 
the conductor; 1 is the current conductor, all other devices 
are performers and will show a status of 0. 

6) The condPriority column shows the conductor priority for all 
devices. The conductor will be the device on the network 
with the highest conductor priority. Conductor priority val-
ues range from 0 to 255, with 255 being the highest conduc-
tor priority. To change the conductor priority, right-mouse 
click on a device and select Configure. Then in the CobraNet 
Configuration dialog, click on the Advanced button; the Ad-
vanced Configuration dialog will open. (Image at right) 
a) To change the conductor priority, enter a value from 0-

255 in the Conductor Priority field. (32 showing in image 
at right) 

b) Not all CobraNet manufacturers allow users to change the Conductor Priority.  
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Recommended Practices for Large Systems 
 
1) Set all RHAON devices to use a fixed startup IP; see Network Manager section above 

for procedure. 
2) Increase the Offline Timeout setting in 

RHAON by 10 seconds for every additional 
25 devices beyond the first 25 on the net-
work. (1-25 devices = 10 sec.; 25-50 de-
vices = 20 sec.; 50-75 devices = 30 sec.; 
etc.) Click Options > Preferences  > 
Advanced tab. (Image at right) 

3) If sending CobraNet audio, double-check 
conductor priority to be sure that the source 
device has the highest conductor priority. 
See the CobraNet Discovery section above 
for the procedure. 

4) Minimize network traffic during system 
setup by disabling all CobraNet transmitters. This is especially helpful during beam 
loading and preset copy/paste. If you need to send audio, use Unicast bundles until 
the system setup is finished. Using multi-cast bundles—especially multiple multi-cast 
bundles, can really slow down the control traffic that RHAON depends on. 


